Wahoo / D-fly users - missing Di2 gearing data? It's not just you

UPDATE August 25: The issue has been fixed in the firmware update Wahoo have released today. If you're still experiencing problems please use the Wahoo app to check for updates. Users have confirmed that the update fixes the problem.

Original post:

If you have a Wahoo ELEMNT Bolt or Roam and also use a Di2 D-Fly or MTB display you may have noticed that your gear display has gone blank.

It seems Wahoo have broken part of this functionality in one of their recent updates. The strange thing is that the data will still work and display if you're in manual shift mode, but bugged in Shift mode 1 and Shift mode 2 (the synchronized shift modes).

The affected devices and firmware versions are:

Wahoo ELEMNT Bolt

Firmware version: WB15 - 8214
Date:: August 18, 2020

Wahoo ELEMNT Roam

Firmware version: WR18 - 8214
Date:: August 18, 2020

Some users have reported fixing this using a factory reset, but others were not so lucky. Other users have not experienced this issue at all. If you do try the factory reset please take soe photos of your screens, so you can set them up just the way you like after the reset.

If you are experiencing problems with this, feel free to let Wahoo know. They already know, of course - but it doesn't hurt to be added to the list. Also, they'll open a ticket for you and keep you updated.

Thank you for letting us know about your experience. This is an issue we are aware of and we have opened an internal ticket with our development team to investigate and resolve the problem

You can submit a support ticket right here: https://support.wahoofitness.com/hc/en-us/requests/new